매일 행복할 준비를 하는 사람

CentOS 에서 Lazarus 설치하고 Linux용 프로그램 만들기 본문

프로그래밍/etc.

CentOS 에서 Lazarus 설치하고 Linux용 프로그램 만들기

키란디아 2009. 4. 5. 07:03

리눅스에서 설치가 힘들다는 글이 있어서...

한번 시험삼아서 설치해봤다.

예전에 Kylix 설치할때는 삽질도 많이 했지만 요즘엔 참 많이 편해졌다.


작년 10월쯤에 Sun VirtualBox 에 설치해둔 CentOS 5.2 에 설치하기로 했다.

오랜만에 켜서 그런지 업데이트 한번 돌린후에 프로그램을 다운 받았다.

다운 받을 것은 3가지 인데 아래와 같다.

그외에 추가로 설치하고 싶은것이 있으면 아래 링크에서 받아서 설치하면 되겠다.

아래와 같이 다운 받는다.


다운 받은후 아래와 같이 설치한다.
rpm -ivh fcp-2.2.2-0.i386.rpm
rpm -ivh fpc-src-2.2.2-081004.i386.rpm
rpm -ivh lazarus-0.9.26.2-0.i386.rpm


설치하면 gdk 관련 오류가 발생할 것이다.
[root@localhost src]# rpm -ivh lazarus-0.9.26.2-0.i386.rpm
오류: Failed dependencies:
        fpc = 2.2.2-0 is needed by lazarus-0.9.26.2-0.i386
        fpc-src = 2.2.2 is needed by lazarus-0.9.26.2-0.i386
        gdk-pixbuf is needed by lazarus-0.9.26.2-0.i386
        gtk+ is needed by lazarus-0.9.26.2-0.i386
        libgdk-1.2.so.0 is needed by lazarus-0.9.26.2-0.i386
        libgdk_pixbuf.so.2 is needed by lazarus-0.9.26.2-0.i386
        libglib-1.2.so.0 is needed by lazarus-0.9.26.2-0.i386
        libgtk-1.2.so.0 is needed by lazarus-0.9.26.2-0.i386

아래와 같이 쳐서 관련 파일들을 설치해준다.
yum install gdk-pixbuf


쉘상에서 아래 명령어를 쳐서 실행 시킨다.
startlazarus




컴파일 해보면 아래와 같은 오류가 나는데
/usr/bin/ld: cannot find -lXi

이 문제는 아래와 같이 처리 한다.

find / -name libXi* 해보면 /usr/lib 에 해당 파일이 있는것을 알수 있는데 /usr/lib 들어간후에 아래와 같이 입력해준다.

find / -name libXi*
cd /usr/lib
ln -s libXi.so.6.0.0 libXi.so


이제 컴파일 하면 문제없이 실행 되는것을 확인 할수 있다.

1 Comments
댓글쓰기 폼